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はじめにはじめにはじめにはじめに 

この度は、KEIm 製品をお買い上げいただき誠にありがとうございます。 

本製品をご使用になる前に、本マニュアル及び関連資料を十分ご確認いただき、使用上の注意を守って正しく 

ご使用ください。 

 

 

 

取扱い上の注意取扱い上の注意取扱い上の注意取扱い上の注意 

 

�  本書に記載されている内容は、将来予告なく変更されることがあります。本製品のご使用にあたっては、  

弊社窓口又は弊社ホームページなどで最新の情報をご確認ください。 

�  本製品には一般電子機器用部品が使用されています。極めて高い信頼性を要求する装置（航空、宇宙機

器、原子力制御機器、生命維持のための医療機器等）には使用しないでください。 

�  本製品は国内使用を前提として開発及び製造を行っています。本製品又は本製品を組み込んだ製品を 

輸出される場合は、お客様の責任において「外国為替及び外国貿易法」及びその他輸出関連法令等を 

順守し、必要な手続きを行ってください。 

�  LAN、USB 以外のコネクタへのケーブルの抜き差しは、必ず電源を OFF にした状態で行ってください。 

�  水、湿気、ほこり、油煙等の多い場所では使用しないでください。 

�  本製品の関連資料の全部又は一部を弊社に無断で使用または複製することを禁止します。 

�  本書及び関連資料で取り上げる会社名及び製品名等は、各メーカーの商標または登録商標です。 

 

お問い合わせお問い合わせお問い合わせお問い合わせ先先先先 

�  製品に関するお問い合わせは、下記のメールアドレスよりお願いいたします。 

keim-support@kd-group.co.jp 
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1. 概要概要概要概要 

本書は KEIm SoM 開発キットを使用してソフトウェアを開発する際の簡易チュートリアルガイドです。開発は

Altera
® FPGA 開発ツール Quartus

®
 II Design Software（以降 Quartus) 及びそれに含まれるツール Nios

®
 II 

Embedded Design Suite (以降 Nios II EDS) を使用して行います。本書ではこれらのツールを使用して次の内

容を実施します。 

①Hello World 表示プログラム作成及び動作確認 

②LED 点滅プログラム及び動作確認 

③プログラムの ROM 化及び Flash ROM 書き込み 

 

1.1. 開発環境 

 

 

 名称 補足 

① ベースボード KEIm-08SoM 搭載済み 

② 開発用 PC 

OS： Windows7 64bit 

開発ツール *2 ： Quartus II Design Software v15.0 以降及び 

Nios II Embedded Design Suite v15.0 以降 

ターミナルソフト： TeraTerm 

③ Altera 社 USB-Blaster
TM

 別売り *1 

④ AC アダプタ KEIm SoM 開発キットに同梱 

⑤ USB mini B ケーブル KEIm SoM 開発キットに同梱 

⑥ KEIm SDK 弊社 Web サイト(http://www.kd-group.co.jp/info/)よりダウンロード 

*1 本製品には USB-Blaster は付属しません。ご利用の際は、取扱販売店又は代理店などを通じ別途ご

購入ください。 

*2 本書では Quartus II Design Software v15.0.0.145 を例として示します。それ以降のバージョンはバージ

ョンを読み替えて参照してください。 

 

①

②

③

④

⑤
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2. 開発準備開発準備開発準備開発準備 

2.1. Quartus のインストール 

KEIm SoM 開発キットを使用してソフトウェア開発を行うためには、Altera 社の FPGA 開発ツール Quartus 

及び Nios II EDS が必要です。開発用 PC にはあらかじめこれらのツールをインストールする必要があります。 

ツールのダウンロード及びインストール方法は Altera 社のホームページをご参照ください。 

http://www.altera.co.jp/products/software/sfw-index.jsp 

 

Nios II EDS は Quartus をインストールする際に合わせてインストールされます。 

 

2.2. USB シリアルのドライバインストール 

KEIm SoM 開発キットの USB 通信は、USB シリアル IC FT232RQ (FTDI) を介して行われます。 

これを使用するためには FTDI 社製の Virtual COM Port ドライバ(以降 VCP ドライバと称す) のインストールが

必要です。以降でそのインストール方法及び VCP ドライバの設定方法を記載します。 

 

2.2.1. VCP ドライバのインストール 

既にインストールしたことのある PC であれば、ベースボードと開発用 PC を USB mini B ケーブルで接続すると

USB シリアルのドライバのインストールが始まります。もし自動的にインストールされない場合は、FTDI 社サイト

の下記 URL より Windows 用の VCP ドライバをインストールしてください。 

http://www.ftdichip.com/Drivers/VCP.htm 

(2015 年 8 月現在 2.12.06 WHQL Certified が Windows 用の最新版ドライバです。) 
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2.2.2. VCP ドライバの設定 

VCP ドライバのデフォルトの設定は、データの待ち時間が長めに設定されており、このチュートリアルの用途に

対してレスポンスが悪いため、VCP ドライバの設定を行います。 

 

① Windows のデバイスマネージャーを立ち上げます。 

 

デバイスマネージャー画面 

 

②設定を行う USB Serial Port (COM**)を選択しプロパティを表示し、 ポート設定タブ＞詳細設定を 

選択します。 

 

USB Serial Port (COM**) のプロパティ画面 
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③詳細設定画面の BM オプションをデフォルトの 16→1 に変更します。 

 

COM**の詳細設定画面 

 

④OK を選択し設定画面を閉じます。これで VCP ドライバの設定完了ですので、プロパティ画面も OK を 

選択し設定画面を閉じます。デバイスマネージャーも終了します。この時、場合によっては Windows の再起動を 

要求されますので、その場合は再起動を実行します。 

 

⑤VCP ドライバの設定を反映するために一度ベースボードに接続している USB ケーブルを抜き、 

再度差し込みます。これで、VCP ドライバの設定が USB シリアル IC に反映されます。 
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3. プログラム作成プログラム作成プログラム作成プログラム作成 

ここでは、Nios II EDS を使用して下記 2 種類のプログラムを作成、その後 KEIm SoM 開発キットを使用して 

動作確認を行います。作成するプログラムは下記 2 種類とします。 

①Hello World 表示プログラム作成 

②LED 点滅プログラム 

 

3.1. Hello World 表示プログラム 

開発環境のセットアップで行った UART 接続(USB シリアル)のコンソール出力に”Hello World”を出力する 

プログラムを作成します。主な作業手順としては下記の通りとなります。 

①BSP の作成 

②SDK ソースファイルのインポート 

③プログラムの作成 

④プロジェクトのビルド 

⑤プログラムの実行 

以降の説明に従ってプログラムの作成及び実行を行ってください。 

 

3.1.1. Nios II SBT の起動 

プログラムのビルドやデバッグにはNios II Software Build Tools for Eclipse (以降Nios II SBT) を使用します。

スタートメニューより Nios II SBT を立ち上げます。スタートメニューより順に 

Altera 15.0.0.145 > Nios II EDS 15.0.0.145 > Nios II 15.0 Software Build Tools for Eclipse を選択し 

Nios II SBT を起動します。 

 

Nios II SBT 立ち上げ時に Workspace の設定のダイアログが表示されますので、適切な場所に Workspace の

パスを設定してください。本書では例として C:¥KEIm_SDK¥workspace をワークスペースフォルダとしています。

ワークスペースフォルダの選択をし OK をクリックすると Nios II SBT メイン画面が立ち上ります。 

 

 

Workspace の指定 
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Nios II SBT メイン画面 
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3.1.2. BSP の作成 

Nios II SBT でソフトウェアを開発する場合、BSP プロジェクトとアプリケーション側のプロジェクトの 2 つが必要

です。ここではまず BSP プロジェクトを作成します。 

 

3.1.3. sopcinfo ファイルのコピー 

BSP の作成には KEIm の FPGA 構成定義ファイルである keim08core.sopcinfo を使用します。弊社 Web サイ

トより keim08core.sopcinfo ファイルをダウンロードし、KEIm_SDK フォルダにコピーしてください。 

 

Nios II SBT のメニューから File > New > Nios II Board Support Package を選択し、下記赤枠部分を設定後、

Finish をクリックします。Project name は任意ですがここでは keim_sdk_bsp とします。 

 

Nios II Board Support Package 設定画面 
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3.1.4. BSP の設定 

標準出力や使用メモリの選択をするために BSP の設定を行います。 

BSP プロジェクトを作成すると Nios II SBT の Project Explorer 上に Project name で指定したフォルダが作成

されます。そのフォルダを選択し右クリック > Nios II > BSP EditorGを選択し BSP Editor を立ち上げます。 

 

①メインの設定 

 

BSP Editor 画面(Main タブ) 

 

Main タブの赤枠の部分を設定することにより、システムクロックタイマーの指定や標準入出力先の選択を 

行えます。ここではタイマは timer_0、標準入出力は uart_0 とします。(デフォルトの標準出力は uart_1 に 

なっていますが、本チュートリアルでは USB シリアル側に文字表示をさせるためこれを変更します) 
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②使用メモリの選択 

 

BSP Editor 画面(Linker Script タブ) 

 

Linker Script の赤枠部分を設定することにより各セクションに使用するメモリを指定できます。 

ここではスタックメモリを内蔵 onchip_memory に指定しています。 

 

③BSP の生成 

Generate をクリックし BSP を再生成後、Exit をクリックし BSP Editor を終了します。 
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3.1.5. SDK ソースファイルのインポート 

SDK ソースファイルのインポートには keim_sdk_src_verxx.zip(xx:Version)を使用します。弊社 Web サイトより

keim_sdk_src_verxx.zip ファイルをダウンロードし、KEIm_SDK フォルダにコピーしてください。 

Nios II SBT のメニューより File > New > Nios II Application を選択し、下記赤枠部分を設定後、 

Finish をクリックします。Project name は任意ですがここでは keim_sdk とします。 

又、BSP location は先ほど作成した keim_sdk_bsp を選択します。 

 

Nios II Application 画面 

 

Nios II SBT のメニューより File > Import をクリックし Import を立ち上げます。 

General > Archive File を選択し Next をクリックします。 

 

Import 画面(Select) 
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From archive file: keim_sdk_src_verxx.zip ファイルを指定します。 

Into folder: keim_sdk を指定し Finish をクリックします。 

 

Import 画面(ファイル指定) 
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3.1.6. プログラム作成 

keim_sdk の main.c の main 関数内 /* User program */ の下に 

printf(“Hello World¥n”); 

を記述し、ファイルをセーブします。 

 

main.c 画面 

 

default では UART の標準出力は UART1(RS-232C)になっているため変更します。 

keim_sdk の config.h の下記部分を変更してファイルをセーブします。 

/* STDIO use UART ch */の下の 

#define CONFIG_DEBUG_USE_UART 

CONFIG_DEBUG_UART1 を CONFIG_DEBUG_UART0 

 

config.h 画面 
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3.1.7. プロジェクトのビルド 

Nios II SBT のメニューより Project > Build All を選択し keim_sdk プロジェクト及び keim_sdk_bsp プロジェクト

の両方をビルドします。Console 上に Error が表示されず、”Build Finished”が表示されればビルドが完了し、

keim_sdk フォルダ内に keim_sdk.elf ファイルが出力されます。 

 

Build 完了後画面 
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3.1.8. プログラムの実行 

ここでは、作成した Hello World 表示プログラムを KEIm SoM へダウンロードし、プログラムを実行する手順を 

記載します。 

 

①ベースボードの電源を ON 

SW7 を ON にし、電源を入れます。電源が入るとベースボード上の LED9 が点灯します。 

 

②ターミナルソフトの起動 

TeraTerm を起動し、通信ポート(COM 番号)及び通信フォーマットを設定します。 

TeraTerm のメニューより設定 > シリアルポート(E)Gを選択し下記画面を立ち上げます。 

このうちポートは使用するポートを選択し、その他の通信フォーマットは下記の通り設定してください。 

設定が終われば OK をクリックします。 

 

Tera Term シリアルポート設定画面 

③Run Configurations 

Nios II SBT のメニューより Run > Run ConfigurationsGを選択し、Run Configurations 画面（下図）を 

立ち上げる。次に、左側に表示されている Configuration Type 中 Nios II Hardware を選択し 

右クリック > New を選択します。 

 

Run Configurations 画面 
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④Project タブの Project name を使用するプロジェクトに設定します。 

 

 

⑤Target Connection タブの Refresh Connections をクリックし、Processors 欄に下図の様に SoM 内の 

Nios II 情報が表示されることを確認します。 

  

 

上記の設定が完了後、Apply をクリックした後、Run をクリックするとプログラムが KEIm SoM へ 

ダウンロードされ、その後実行されます。プログラムを実行した結果、ターミナルへ”Hello World”が 

表示されます。 
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実行後のターミナル画面 

 

プログラムを再度実行する場合、Project Explorer 上で keim_sdk フォルダを選択し、 

右クリック > Run As > Nios II Hardware を選択すれば実行できます。 

 

3.1.9. プログラムのデバッグについて 

デバッグする際は、Project Explorer 上で keim_sdk フォルダを選択し、右クリック > Debug As > Nios II 

Hardware を選択するとデバッガが起動します。詳しいデバッガの使い方は、Altera 社のホームページより    

ご確認ください。 
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3.2. LED 点滅プログラム 

LED の点滅を行うプログラムを作成します。 

 

3.2.1. ソースファイル 

LED の点滅を行うサンプルアプリケーション LedApplSampleSoft.zip を弊社 Web サイトよりダウンロードして御

使用ください。LedApplSampleSoft.zip を解凍すると以下のフォルダ構成になっております。 

LedApplSampleSoft doc LED_sample_application_manual_v1.0.0.pdf 

src LedSampleApl.c 

LedSampleApl.h 

main.c 

 

LED のサンプルアプリケーションの詳細は解凍後の LedApplSampleSoft フォルダ > doc にある 

アプリケーションマニュアルを参照ください。 

 

①Nios II SBT のメニューより File > New > Nios II Application を選択し、下記赤枠部分を設定後、 

Finish をクリックします。 

Project name は任意ですがここでは LEDApplSampleSoft とします。 

又、BSP location は keim_sdk_bsp 選択します。 

 

Nios II Application 画面 
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②Nios II SBT のメニューから File > Import をクリックし Import を立ち上げます。 

General > Archive File を選択し Next をクリックします。 

 

Import 画面(Select) 

 

From archive file: keim_sdk_src_verxx.zip ファイルを指定します。 

Into folder: LEDApplSampleSoft を指定し Finish をクリックします。 

 

Import 画面(ファイル指定) 
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③Nios II SBT のメニューから File > Import をクリックし Import を立ち上げます。 

General を選択すると General の下にサブメニューが表示されますので、”File System”を選択した状態で 

Next をクリックします。 

 

Import 画面(Select) 

 

④From directory:で先ほど解凍したフォルダを選択してください。 

出てきたフォルダにチェックを入れてください。 

IntoFolder:LEDApplSampleSoft/keim_sdk_src を指定し、Finish をクリックします。 

 

Import 画面(ファイル指定) 

 

全て上書きをします。 
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3.2.2. LED 点滅プログラムの実行 

プログラムを実行するために下記の手順を実施してください。 

Hello World 表示プログラムで実施したのと同じ手順でプロジェクトのビルド～実行をします。 

 

①Nios II SBT のメニューより Project > Build All を選択しビルドを実行します。 

②Nios II SBT の Project Explorer 上で LedApplSampleSoft フォルダを選択し、 

右クリック > Run As > Nios II Hardware の順に選択します。 

 

プログラムが実行されると LED が全点灯します。ベースボードの SW1 を押すたびに LED の点灯状態が 

変わります。 
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4. プログラムのプログラムのプログラムのプログラムの ROM化及び化及び化及び化及び Flash ROM書き込み書き込み書き込み書き込み 

プログラムの ROM 化及び Flash ROM への書き込みは Nios II EDS の Flash Programmer で行います。 

下記の手順に沿って実行してください。 

 

①ベースボードの電源を ON 

SW7 を ON にし、電源を入れます。電源が入るとベースボード上の LED9 が点灯します。 

 

②Flash Programmer の起動 

Nios II SBT のメニューから Nios II > Flash Programmer を選択し、Flash Programmer を起動します。 

 

Flash Programmer メイン画面 
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③New Flash Programmer Settings 

メニューより File > NewGを選択すると New Flash Programmer Settings File 画面が現れます。 

下図に従い赤枠部分を設定し OK を選択します。  

 

New Flash Programmer Settings 画面 

 

④Hardware Connections 

Flash Programmer メイン画面で ConnectionsGを選択すると Hardware Connections 画面が表示されます。

Hardware Connections 画面で Refresh Connections を選択し Processrors 欄に下記表示がされていることを

確認し Close を選択してください。表示されない場合、ベースボードの電源が入っているか再度確認して 

ください。 

 

Hardware Connections 画面 
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⑤ROM 書き込みファイルの設定 

AddGを選択し、ROM へ書き込むためのファイル(.elf)を選択してください。 

 

ROM 書き込みファイルの選択 

 

⑥プログラムの実行 

Start を選択すると、ROM へのプログラムが実行され、Processing ウィンドウに 

”Leaving target processer pused”が表示されればプログラム完了です。 

 

書き込み完了画面 
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5. サンプルアプリケーションについてサンプルアプリケーションについてサンプルアプリケーションについてサンプルアプリケーションについて 

本書で紹介しました LED 点滅アプリケーションの他に、以下のサンプルアプリケーションを用意しております。詳

細に関しましては各々のアプリケーションマニュアルを参照ください。 

 

 アプリ名称 概要 

1 ADCApplSampleSoft  
DAC から SIN 波を出力し、ADC からループバックされたデータを取得し

UART0 へ出力します。 *1 

2 BuzzerApplSampleSoft ボタンが押下されるとブザーが鳴ります。 

3 EtherApplSampleSoft 
ネットワークから入力されたコマンドに伴い、ADC、Buzzer、LED、

RTC、サーボモータ及びステッピングモータを動作させます。 *2 

4 RtcApplSampleSoft 
日付（固定データ）を RTC に書き込み、年月日時分秒を標準出力へ 

出力します。 

5 ServoApplSampleSoft ボタンが押下されるとサーボモータが動作します。 *2 

6 SteppingApplSampleSoft ボタンが押下されるとステッピングモータが動作します。 *2 

*1 ループバックは DAC 出力と ADC 入力をベースボード外部でショートして行っています。 

*2 サーボモータ及びステッピングモータ及びステッピングモータのドライブ回路は KEIm SoM 開発キット

には付属しません。 
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6. 更新履歴更新履歴更新履歴更新履歴 
Ver. 更新日付 内容 

1.0.0 2015/09/14 新規作成 

1.1.0 2016/04/14 ・1. 概要に Quartus Prime を追記 

・各種データ入手元の記載を”CD-ROM”から”弊社 Web サイトよりダウンロ

ード”に変更 

   

   

   

   

 

 

 

 

 


