
 

 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ver.1.0 

 

 

 

 

 

 

 

 

 

 

 

 

 

  株式会社近藤電子工業 

KEIm-08SoM 

ヘッダーボード 

スタートアップガイド 



 

 
 
 

はじめに 

この度は、KEIm製品をお買い上げいただき誠にありがとうございます。 

本製品をご使用になる前に、本マニュアル及び関連資料を十分ご確認いただき、使用上の注意を守って正しく 

ご使用ください。 

 

 

 

取扱い上の注意 

 

  本書に記載されている内容は、将来予告なく変更されることがあります。本製品のご使用にあたっては、  

弊社窓口又は弊社ホームページなどで最新の情報をご確認ください。 

  本製品には一般電子機器用部品が使用されています。極めて高い信頼性を要求する装置（航空、宇宙機

器、原子力制御機器、生命維持のための医療機器等）には使用しないでください。 

  本製品は国内使用を前提として開発及び製造を行っています。本製品又は本製品を組み込んだ製品を 

輸出される場合は、お客様の責任において「外国為替及び外国貿易法」及びその他輸出関連法令等を 

順守し、必要な手続きを行ってください。 

  LAN、USB以外のコネクタへのケーブルの抜き差しは、必ず電源を OFFにした状態で行ってください。 

  水、湿気、ほこり、油煙等の多い場所では使用しないでください。 

  本製品の関連資料の全部又は一部を弊社に無断で使用または複製することを禁止します。 

  本書及び関連資料で取り上げる会社名及び製品名等は、各メーカーの商標または登録商標です。 

 

お問い合わせ先 

  製品に関するお問い合わせは、下記のメールアドレスよりお願いいたします。 

keim-support@kd-group.co.jp 

 

 

  

file://///y-server/yokohama/案件/社内事業/2.Max10SoM_step2/開発設計データ/作成資料/C_ソフト関連/サンプルプログラム/仕様書/master/変更後/keim-support@kd-group.co.jp
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1. 概要 

本書は KEIm-08SoMヘッダーボードを使用してソフトウェアを開発する際のスタートアップガイドです。開発はイ

ンテル® FPGA開発ツール Quartus
®
 Prime

®
 開発ソフトウェア（以降 Quartus Prime) 及びそれに含まれるツ

ール Nios
®
 II Embedded Design Suite (以降 Nios II EDS) を使用して行います。本書ではこれらのツールを使

用して次の内容を実施します。 

① Hello World表示プログラム生成及び動作確認 

② LED点滅プログラム及び動作確認 

③ プログラムの ROM化及び Flash ROM書き込み 

 

1.1. 開発環境 

 

 

 

 

 名称 補足 

①  ヘッダーボード KEIm-08SoM搭載済み 

②  開発用 PC 

OS： Windows7 64bit 

開発ツール *2 ： Quartus Prime Design Software v18.1.0以降及び 

Nios II Embedded Design Suite v18.1.0以降 

③  Intel FPGA Download Cable II
TM

 USB-Blaster II
TM 
別売り *1 

④  USB mini Bケーブル KEIm SoM開発キットに同梱 

*1 本製品には USB-Blaster IIは付属しません。ご利用の際は、取扱販売店又は代理店などを通じ別途

ご購入ください。 

*2 本書ではQuartus Prime Design Software v18.1.0.625を例として示します。それ以降のバージョンはバ

ージョンを読み替えて参照してください。 

 

① 

② 

③ 

④ 
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2. 開発準備 

2.1. Quartus Primeのインストール 

KEIm SoM開発キットを使用してソフトウェア開発を行うためには、インテル社の FPGA開発ツール Quartus 

Prime 及びNios II EDSが必要です。開発用 PCにはあらかじめこれらのツールをインストールする必要があり

ます。 

ツールのダウンロード及びインストール方法はインテル社のホームページをご参照ください。 

https://www.intel.co.jp/content/www/jp/ja/software/programmable/quartus-prime/overview.html 

 

Nios II EDSは Quartus Primeをインストールする際に合わせてインストールされます。 

 

2.2. KEIm08 用 FPGAサンプルデザインを開発用 PCにコピー 

弊社WEBサイトより “keim08_tiny_fast_q181.zip”をダウンロードして開発用PCにコピーしてください。 

このデザインは、Nios
®
 II/f “Fast” core を使用しています。 Nios

®
 II/f を含む FPGAデザインをコンパイルす

る場合は、 IPS-EMBEDDED または IP-NIOS のライセンスが必要です。 

これらのライセンスがない場合は、Nios
®
 II/e “Economy” coreを使用した “keim08_tiny_economy_q181.zip” 

をダウンロードしてください。 

 Quartus Primeのライセンスに Nios
®
 II “Fast” core を例として下記フォルダに格納して解凍した場合に

て、以降の説明を進めます。Nios
®
 II/e “Economy” core版をご使用の場合は、フォルダ名を読み替えてくださ

い。 

 

Nios
®
 II/f “Fast” coreの場合 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181.zip 

解凍後のフォルダ 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥ 

Nios
®
 II/e “Economy” coreの場合 

D:¥intelFPGA¥keim08¥ keim08_tiny_economy_q181.zip 

解凍後のフォルダ 

D:¥intelFPGA¥keim08¥ keim08_tiny_economy_q181¥ 

 

Nios
®
 II のコアの違いは下記サイトを参照してください。 

https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii.html?_ga=2.61131300.928

125466.1538442790-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302 

ライセンスに付きましては、下記サイトを参照してください。 

https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii/embedded-ip-suite.html?_g

a=2.176649189.1554389885.1538442905-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302 

https://www.intel.co.jp/content/www/jp/ja/software/programmable/quartus-prime/overview.html
https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii.html?_ga=2.61131300.928125466.1538442790-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302
https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii.html?_ga=2.61131300.928125466.1538442790-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302
https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii/embedded-ip-suite.html?_ga=2.176649189.1554389885.1538442905-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302
https://www.intel.co.jp/content/www/jp/ja/products/programmable/processor/nios-ii/embedded-ip-suite.html?_ga=2.176649189.1554389885.1538442905-1762824604.1533265000&elq_cid=3705377&erpm_id=6734302
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3. プログラム作成 

ここでは、Nios II EDSを使用して下記 2種類のプログラムを作成、その後 KEIm SoM開発キットを使用して 

動作確認を行います。作成するプログラムは下記 2種類とします。 

①Hello World表示プログラム 

②LED点滅プログラム 

 

3.1. Hello World表示プログラム 

Nios II EDSのコンソールウィンドウ、または開発環境のセットアップで行った UARTシリアルのコンソール出力

に”Hello World”を出力するプログラムを作成します。 例としての記述は Nios II EDSのコンソールウィンドウを

使用します。 

主な作業手順としては下記の通りとなります。 

① Template から BSP とソースファイルの生成 

② プロジェクトのビルド 

③ プログラムの実行 

以降の説明に従ってプログラムの作成及び実行を行ってください。 

 

3.1.1. Nios II SBTの起動 

プログラムのビルドやデバッグにはNios II Software Build Tools for Eclipse (以降Nios II SBT) を使用します。

スタートメニューより Nios II SBT を立ち上げます。スタートメニューより順に 

Intel FPGA 18.1.0.625 Lite Edition > 

または 

Intel FPGA 18.1.0.625 Standard Edition > 

 Nios II EDS 18.1.0.625 > Nios II Software Build Tools for Eclipse (Quartus Prime 18.1) 

を選択し Nios II SBTを起動します。 

 

Nios II SBT立ち上げ時にWorkspaceの設定のダイアログが表示されますので、適切な場所にWorkspaceの

パスを設定してください。本書では例として D:¥intelFPGA¥keim08¥workspace_KEIm08 をワークスペースフ

ォルダとしています。ワークスペースフォルダの選択をし OKをクリックすると Nios II SBT メイン画面が立ち上り

ます。 

 

Workspaceの指定 
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Nios II SBT メイン画面 
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3.1.2. Nios II Application と BSP を Templateより生成 

Nios II SBT でソフトウェアを開発する場合、BSPプロジェクトとアプリケーション側のプロジェクトの 2つが必要

です。 SBTの Templateを使って両方を生成します。 

 

3.1.3. sopcinfo ファイルのコピー 

BSPの作成には KEImの FPGA構成定義ファイルである”keim08core.sopcinfo”を使用します。 

“ 2.3. KEIm08 用 FPGAサンプルデザインを開発用PCにコピー” の項目で弊社Webサイトよりダウンロード

したファイルに含まれています。 例として下記に格納されています。 

 D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥keim08core.sopcinfo 

 

Nios II SBTのメニューから File > New > Nios II Application and BSP from Template を選択

し、”keim08core.sopcinfo” ファイルをしていします。 また、Templatesの中から Hello World を選択します。 

Project nameは任意ですがここでは keim_hello_world とします。 下記赤枠部分を設定後、[Finish] をクリッ

クします。 
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3.1.4. BSPの設定 

先程生成された BSP の設定を確認（変更）します。 

Nios II > BSP Editor で BSP editor を起動します。 
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BSP Editor が起動しましたら、作成されたプロジェクトの settings.bsp ファイルを読み込みます。 

File > Open > 

本例では、 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥software¥keim_hello_world_bsp¥settings.bsp 

を指定します。 
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④ メインの設定 

   

BSP Editor画面(Main タブ) 

 

Main タブの赤枠の部分を設定することにより、システムクロックタイマーの指定や標準入出力先の選択を 

行えます。ここではタイマは timer_100ms、標準入出力は jtag_uart_0 とします。(デフォルトの標準出力が

jtag_uart_0になっています)  

標準入出力の jtag_uart_0 を uart_0 に変更しますと、USB-UARTを介して Vertual COMポートに設定する

事が出来ます。 

 

＜注意＞ 

但し、JTAG 接続が、”USB-Blaster” の場合は、USB-UART と ” USB-Blaster” は同一の PCを使用する事

は出来ません（FTDIのドライバが競合する為）。 

JTAG 接続が、” USB-Blaster II” の場合は、ドライバの競合がおきませんので、同一の PCで使用可能です。 
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② 使用メモリの選択 

    

BSP Editor画面(Linker Script タブ) 

 

Linker Scriptの赤枠部分を設定することにより各セクションに使用するメモリを指定できます。 

ここではスタックメモリを内蔵 onchip_memoryに指定しています。 

 

③ BSPの生成 

設定が完了しましたら、 File > save で上書き保存します。 

[Generate] をクリックし BSPを再生成後、[Exit] をクリックし BSP Editorを終了します。 
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3.1.5. ソフトウェアプロジェクトのビルド 

プロジェクト “Keim_hello_world” を選択後、Project> Build Project を実行します。 
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3.1.6. FPGA内部回路イメージの download 

本プロジェクト用の FPGA内部回路イメージファイルは”keim08_top.sof” を使用します。 先程

の”keim08core.sopcinfo” と同様に下記フォルダに格納されています。 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥output_files¥keim08_top.sof 

 

スタートメニューより Quartus Prime Programmer を立ち上げます。スタートメニューより順に 

Intel FPGA 18.1.0.625 Lite Edition > 

Quartus Prime Lite Edition 18.1.0.625 > Programmer (Quartus Prime 18.1) 

または 

Intel FPGA 18.1.0.625 Standard Edition > 

Quartus Prime Standard Edition 18.1.0.625 > Programmer (Quartus Prime 18.1) 

 

を選択し Quartus Prime Programmerを起動します。 

 

① Intel FPGA download cable II の Hardware Setup 

Hardware Setup > USB-Blaster II (USB-1) を選択します。 
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Auto Detect > 10M08SC を選択して[OK] 

 

 

”keim08_top.sof”の設定 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥output_files¥ keim08_top.sof 

File<none> をダブルクリックして”keim08_top.sof”ファイルを選択して[Open] 
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② Download を実行 

Program/Configure にチェックを入れて Start 
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3.1.7. ソフトウェアプロジェクトの実行 

3.1.5項でビルドしたソフトウェアプロジェクトをメモリに download して実行します。 

 

①  Debug Configurations の設定 
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“Nios II Hardware” をダブルクリックしますと、New_configuration が現れますので、ここでは Name 例

として keim08_samples とします。  
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次に”Target Configration” のタブを開き “System IC checks” の下記２項にチェックマークを付けます。 

 ☑ Ignore mismatched system ID 

 ☑ Ignore mismatched system timestamp 

その後、[Refresh Connection] のボタンを押します。 
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Processors: / Bye Stream Devices: の項目 (        )がリフレッシュ（一旦消えて再度表示）されまし

たら [Apply] ボタンを押してから [Debug] ボタンを押して Debugger を起動します。 

    

 

下記 Confirm Perspective Switch のダイアログが現れましたら [Yes] を押してください。 
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②  Breakpointを設定して実行 

NiosII Debug が起動しましたら、 hello_world.c の 

23  return 0; 

の行の 23 の文字の少し左側にマウスカーソルを持っていきダブルクリックしますと Breakpoint のマー

クが付きます。次に Nios II Console をドラッグアンドドロップで見やすい位置に移動しておきます。 
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その後、  ボタンを押してソフトウェアを実行します。 

NiosII Console ウィンドウに 

Hello from Nios II! 

が表示されて breakpoint で止まります。 

Terminate    ボタンを押して Debug を終了します。 
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3.2. LED点滅プログラム 

2.2項で解凍した下記フォルダに、LED点滅プログラム “hello_led.c” がありますので、それを新規作成する 

Applecation プロジェクトにコピーします。 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥software¥examples¥hello_led.c 

主な作業手順としては下記の通りとなります。 

① 新規 Applecation プロジェクトの作成し、BSPを Hello World表示プログラムで作成した BSPに設定 

② hello_led.cをコピーe 

③ プロジェクトのビルド 

④ プログラムの実行 

以降の説明に従ってプログラムの作成及び実行を行ってください。 

 

 

3.2.1. 新規 Applecation プロジェクト作成と BSPの設定 

LED 点滅プログラム用に新規 Applecation プロジェクトを作成し、BSP は先程の hello_world の BSP を設

定します。 Nios II SBT のウィンドウに戻り、 

 File > New > Nios II Application を選択します。 
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Project name : をここでは keim_hello_led とします。 

    

BSP location: の右端の  をクリックして先程の keim_Hello_world_bsp を選択します。 
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下記設定になりましたら [Finish] します。 

    

3.2.2. hello_led.c をコピー 

エクスプローラで下記 “hello_led.c” を選択し、Drag and dropで keim_hello_led のプロジェクト

にコピー 

D:\intelFPGA\keim08\keim08_tiny_fast_q181\software\examples\hello_led.c 

 

 

File Operation のダイヤログボックスが現れましたら、 Copy file を選択して[OK] 
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3.2.3. プロジェクトのビルド 

keim_hello_led のプロジェクトを選択し、Project > Build Project を実行 
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3.2.4. プログラムの実行 

① hello_world と同様、Quartus Prime Programmer （ Hello_worldの時の設定のまま） ”keim08_top.sof” 

を download します。 

   

 

② keim_hello_led を選択して Run > Debug Configurations… を選択 
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③ Project name: を keim_hello_led を選択 

  

④ Target Connection のタブを開いて、Refresh Connections を実行 

   

Refreshが完了後、 [Apply] > [Debug] を実行  
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> Confirm Perspective Switch [Yes] を実行 

 

  

 

⑤  Debug が起動しましたら、  

36 usleep(wait_time); の行に breakpoint を設定 

 

   

 

その後、  ボタンを押してソフトウェアを実行します。 
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Breakpoint で停止する毎に、LED の点灯と NiosII console へのメッセージを確認し、  ボタンを押し

てソフトウェアを継続実行繰り返します。 

led_data = 0 : 両方消灯 

led_data = 1 : LED2 だけ点灯 

led_data = 2 : LED1 だけ点灯 

led_data = 3 : 両方点灯 

 

   

 

一通り動作が確認出来ましたら、Breakpoint を外して、  ボタンを押してソフトウェアを連続動作さ

せます。 
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 ボタンで一時停止 

 ボタンで terminate 出来ます。 
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4. FPGA デザインの書き込み 

FPGA デザインをインテル® 
MAX

®
 10 FPGA 内蔵の Flash ROM へ書き込みます。 

“ 2.3 KEIm08 用 FPGAサンプルデザインを開発用 PCにコピー”項でコピーしたファイルの中に書き込みフ

ァイルが含まれていますので、それを Quartus Prime Programmer を使用して書き込みます。 

4.1. Quartus Prime Programmerでの書き込み 

  Quartus Prime Programmer の設定は、download する.sof ファイルになっているかと思いますので、

これを Flash memory 書き込みファイルの .pof ファイルに変更します。 

“keim08_top.sof”ファイルをダブルクリックしますと下図の様に Select New Programming File のダイ

ヤログボックスが現れますので、”keim08_top.pof”を選択し、[Open] を押します。 

 

書き込みファイルが設定されますので、 Program/Configure と Verify にチェックマークを設定し、[Start] 

を押しますと書き込みが実行されます。 

   

Progress が 100%(Successful) となれば完了です。 
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5. プログラムの ROM 化及び Flash ROM 書き込み 

プログラムの ROM化及び Flash ROMへの書き込みは Nios II EDSの Flash Programmerで行います。 

下記の手順に沿って実行してください。 

 

① Flash Programmerの起動 

Nios II SBTのメニューから Nios II > Flash Programmerを選択し、Flash Programmerを起動します。 

  

Flash Programmer メイン画面 
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② New Flash Programmer Settings 

メニューより File > New…を選択すると New Flash Programmer Settings File画面が現れます。 

下図に従い赤枠部分を設定し[OK] を選択します。  

 

SOPC Information File name : に 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥keim08core.sopcinfo 

を選択します。 
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New Flash Programmer Settings画面 

③ Hardware Connections 

Flash Programmer メイン画面で Connections…を選択すると Hardware Connections画面が表示されます。

Hardware Connections画面で Refresh Connectionsを選択し Processrors欄        に下記表示がされて

いることを確認し[Close] を選択してください。 

 

Hardware Connections画面 
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④ Flash ROM書き込みファイルの設定 

[Add…] を選択し、Flash ROMへ書き込むためのファイル(.elf)を選択してください。 

本例では、下記フォルダより “keim_hello_led.elf”を選択します。 

D:¥intelFPGA¥keim08¥keim08_tiny_fast_q181¥software¥keim_hello_led¥keim_hello_led.elf 

 

 

Flash ROM書き込みファイルの選択 
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書き込みファイル設定完了 

⑤ Flash ROM書き込みの実行 

[Start] を選択すると、Flash ROMへの書き込みが実行され、Processingウィンドウに 

”Leaving target processer pused” が表示されれば書き込み完了です。 

    

書き込み完了画面 
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6. 補足資料 

6.1. USBシリアルのドライバインストール 

KEIm SoM開発キットの USB通信は、USBシリアル IC FT232RQ (FTDI) を介して行われます。 

これを使用するためには FTDI社製の Virtual COM Port ドライバ(以降VCPドライバと称す) のインストールが

必要です。以降でそのインストール方法及び VCP ドライバの設定方法を記載します。 

 

6.1.1. VCP ドライバのインストール 

既にインストールしたことのある PCであれば、ベースボードと開発用 PCを USB mini Bケーブルで接続すると

USBシリアルのドライバのインストールが始まります。もし自動的にインストールされない場合は、FTDI社サイト

の下記 URLよりWindows用の VCP ドライバをインストールしてください。 

https://www.ftdichip.com/Drivers/VCP.htm 

 (2018年 9月現在 2.12.28 WHQL CertifiedがWindows用の最新版ドライバです。) 

 

https://www.ftdichip.com/Drivers/VCP.htm
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6.1.2. VCP ドライバの設定 

VCP ドライバのデフォルトの設定は、データの待ち時間が長めに設定されており、このチュートリアルの用途に

対してレスポンスが悪いため、VCP ドライバの設定を行います。 

 

① Windowsのデバイスマネージャーを立ち上げます。 

 

デバイスマネージャー画面 

 

② 設定を行う USB Serial Port (COM**)を選択しプロパティを表示し、 ポート設定タブ＞詳細設定を 

選択します。 

 

USB Serial Port (COM**) のプロパティ画面 
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③ 詳細設定画面の BMオプションをデフォルトの 16→1に変更します。 

 

COM**の詳細設定画面 

 

④ [OK] を選択し設定画面を閉じます。これで VCP ドライバの設定完了ですので、プロパティ画面も[OK] を 

選択し設定画面を閉じます。デバイスマネージャーも終了します。この時、場合によってはWindowsの再起動を 

要求されますので、その場合は再起動を実行します。 

 

⑤ VCP ドライバの設定を反映するために一度ベースボードに接続している USBケーブルを抜き、 

再度差し込みます。これで、VCP ドライバの設定が USBシリアル ICに反映されます。 
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7. 更新履歴 

Ver. 更新日付 内容 

1.0.0 2018/10/22 新規作成 
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